Disney Treasures disc won't play - Forum.
Welcome Guest! To enable all features please Login or Register.
Options
Go to last post Go to first unread
Mark The Shark  
#1 Posted : Tuesday, October 30, 2018 12:17:02 AM(UTC)
Mark The Shark

Rank: Advanced Member

Groups: Registered
Joined: 1/8/2015(UTC)
Posts: 53

Thanks: 7 times
Was thanked: 14 time(s) in 10 post(s)
Not long ago I pulled out the Disney Treasures set "Mickey Mouse In Living Color Volume 2" after not having watched it in years. The first disc will not play on two different DVD players. It says "disc error." Other sets of the same vintage are fine, as is the second disc. I don't remember when I last played it, but whenever that was, it was fine.

Anyone else have this happen?

Edited by user Tuesday, October 30, 2018 12:18:58 AM(UTC)  | Reason: Not specified

PopKorn Kat  
#2 Posted : Tuesday, October 30, 2018 12:55:41 AM(UTC)
PopKorn Kat

Rank: Administration

Groups: Registered, Researcher, Administrators, Moderator, Beta Tester
Joined: 1/29/2015(UTC)
Posts: 1,031
Woman
United States
Location: Looney Tune Land

Thanks: 852 times
Was thanked: 357 time(s) in 252 post(s)
Originally Posted by: Mark The Shark Go to Quoted Post
Not long ago I pulled out the Disney Treasures set "Mickey Mouse In Living Color Volume 2" after not having watched it in years. The first disc will not play on two different DVD players. It says "disc error." Other sets of the same vintage are fine, as is the second disc. I don't remember when I last played it, but whenever that was, it was fine.

Anyone else have this happen?


Not me; mine is fine.

Your disc is probably damaged beyond readability. Sorry.
WaltWiz1901  
#3 Posted : Tuesday, October 30, 2018 6:56:39 AM(UTC)
WaltWiz1901

Rank: Advanced Member

Groups: Registered
Joined: 11/25/2017(UTC)
Posts: 295
Man
United States

Thanks: 301 times
Was thanked: 106 time(s) in 85 post(s)
Originally Posted by: Mark The Shark Go to Quoted Post
Not long ago I pulled out the Disney Treasures set "Mickey Mouse In Living Color Volume 2" after not having watched it in years. The first disc will not play on two different DVD players. It says "disc error." Other sets of the same vintage are fine, as is the second disc. I don't remember when I last played it, but whenever that was, it was fine.

Anyone else have this happen?

It hasn't happened to me with this volume, but it did happen on the second disc of my copy of the first volume. I will never forget how much of a struggle it was to get a replacement for it!
Bradskey  
#4 Posted : Tuesday, October 30, 2018 8:27:35 AM(UTC)
Bradskey

Rank: Advanced Member

Groups: Registered
Joined: 12/15/2014(UTC)
Posts: 64

Thanks: 1 times
Was thanked: 12 time(s) in 10 post(s)
Welcome to DVD rot. Although I've not heard of it being such a problem with Disney. Warner Brothers had a lot of animated releases, mostly TV stuff, from the 2006-2008 era, as well as feature films, that have been failing in high numbers in the past few years. Some old Fox releases were affected also. It had to do with the replication vendor they used at that time. Although WB has at least been pretty good at providing replacements. There's a whole thread about it at HTF.

At the end of the day though DVD did not have the longevity built into it that Blu-ray (supposedly) has. If I ever get around to digging out my copy I'll try to test it. I keep digital copies of everything for this reason.
djbbjd  
#5 Posted : Wednesday, January 2, 2019 11:56:26 PM(UTC)
djbbjd

Rank: Newbie

Groups: Registered
Joined: 1/2/2019(UTC)
Posts: 1

Was thanked: 1 time(s) in 1 post(s)
I am having the same problem, but with disc 2 of the Mickey Mouse in Living Color, first volume. There is not a single scratch on my disc, but it is not even recognized. I have just begun to back-upo my discs and hope this is the only problem I run into. These are far too hard to replace. The going price for even used copies is very expensive. I don't care about the value of the disc, only the content. Some of my favorite Mickey shorts are on that second disc.
thanks 1 user thanked djbbjd for this useful post.
WaltWiz1901 on 1/3/2019(UTC)
captchuck  
#6 Posted : Friday, January 4, 2019 6:44:54 AM(UTC)
captchuck

Rank: Newbie

Groups: Registered
Joined: 12/15/2014(UTC)
Posts: 4

Was thanked: 1 time(s) in 1 post(s)
The only treasures disc that I have that won't play is "Mickey Mouse In Living Color Volume 2" Disc one. The problem started with the first cartoon "Society Dog Show" which was suddenly looking very blocky with all kinds of visual stuff that didn't belong there, but the rest of the disc played fine. The last time I tried to play it I got a "disc dirty" message and it wouldn't play at all, but there are no scratches or fingerprints on the disc.

I have most of the other animation "Treasures" and they all work fine. I wonder is this is a problem disc. I played it often as the Mickey cartoons are some of my favorites.
WaltWiz1901  
#7 Posted : Saturday, January 5, 2019 5:25:23 AM(UTC)
WaltWiz1901

Rank: Advanced Member

Groups: Registered
Joined: 11/25/2017(UTC)
Posts: 295
Man
United States

Thanks: 301 times
Was thanked: 106 time(s) in 85 post(s)
Slightly unrelated, but....
-I received More Silly Symphonies: Volume Two yesterday, but of course, the discs I got were the problematic ones (no Amos 'n Andy scene in The Night Before Christmas, reissue titles still intact on numerous black-and-white cartoons, The Merry Dwarfs presented in 1.33:1 instead of in its proper 1.20:1, and many other authoring faults; my copy also came with absolutely no inserts, but that's a completely different issue)
-Similar to the Silly Symphonies set above, my copy of The Chronological Donald: Volume Four has the ending to Bee on Guard (located on disc 1) cut short

Any way I can replace these three particular discs currently?
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Notification

Icon
Error